IrfanView

From TheAlmightyGuru
Jump to: navigation, search
Irfanview displaying an image.

IrfanView is a freeware graphics viewer and organizer program developed by Irfan Škiljan for Windows and released on 1996-06-01. It works fine on Windows 10, but has backward compatible support all the way to Windows XP. It can quickly open an view hundreds of graphic formats and has limited support for some video and audio formats as well. With the base install, the program and display BMP, CUR, EMF, GIF (and animated), ICO, JPEG, Netpbm, PCD, PNG, PSD, TGA, TIFF, WMF. With plugin support, it can view CRW, DDS, ECW, EPS, FLIF, IFF, JPEG 2000, MNG, PCX, PDF, PSP, SGI, WEBP, XBM, and many others.

Personal

After upgrading to Windows 10, I was disgusted that Microsoft had ditched Windows Photo Viewer and replaced it with the Photos application which is malware which is not only slow and bloated, but also uses facial recognition to identify the people in your photos and sends the data back to Microsoft. I searched online for a replacement and found a lot of praise for IrfanView. After trying it out for awhile, and customizing it to my liking, I now prefer it over any other.

Review

Good

  • With such a wide array of supported image formats, this program can replace several viewer programs.
  • There are a lot of customization features to make the program work the way you want.
  • The program is a fantastic replacement for the awful Photos program that comes with Windows 10.
  • Unlike many photo viewers, this doesn't send your private information to a major corporation.
  • The program also includes some primitive photo editing features if you don't have access to a decent editor.
  • Has built-in tools to perform certain modifications to JPEGs without losing quality.

Bad

  • A large portion of the formats are not included in the default installer, and require you to install a second plugin. I would prefer they just all be included in the same installer.
  • By default, the scroll-wheel is set to move to the next image rather than zoom. You also can't use the scroll wheel to zoom, but must use the stupid Adobe method of CTRL+Scroll to zoom. Also, when you can't see the full image if you're zoomed in too far, you can't use the arrow keys to move to the next image.
  • By default, the viewer is set to open a lot of formats you probably won't want it to open, like fonts, text files, and MIDI files. These can be disabled in the settings, but it's not simple. I would prefer a simpler UI which allowed you to easily enable/disable all formats of a specific type like images, video, audio, documents, etc.
  • The default icons are very old and ugly looking.

Ugly

  • Nothing.

Tricks

Loop folder

By default, when you try to go past the last image in a folder (or before the first), IrfanView pops a dialog asking if you want to view another folder. I find this annoying, so I set it to loop the current folder by doing the following:

  1. In the menu, click Options -> Properties/Settings...
  2. In the list, click Browsing.
  3. Under the section "If the end/begin of the folder is reached," select "Loop current folder."
  4. Click OK.

Zoom to window size

By default, IrfanView resizes its window to match the current image. I find this very distracting. To have IrfanView scale the image to the window size, do the following:

  1. In the menu, click View -> Display options (windowed mode).
  2. Select "Fit images to window."

Disable resampling

If you view a lot of screenshots like I do, you may wish to turn off the resampling so pixelated images don't become blurry. To do so, do the following:

  1. In the menu, click View -> Display options (windowed mode).
  2. Uncheck "Use resample for fitting."
  3. In the menu, click View -> Display options (windowed mode).
  4. Uncheck "Use resample for zooming."

Disable recent files

For security reasons, it's wise to disable this feature.

  1. In the menu, click Options -> Properties/Settings...
  2. In the list, click Miscellaneous.
  3. Uncheck "Show recent files."
  4. Uncheck "Show recent folders."
  5. Click OK.

Next after deleting

I prefer the program to move to the next image if you delete an image. To do this, do the following:

  1. In the menu, click Options -> Properties/Settings...
  2. In the list, click File Handling.
  3. Check "Jump to the next file after deleting/moving."
  4. Click OK.

JPEG 2000 support

By default, IrfanView doesn't support JPEG 2000. To get it working, do the following:

  1. Close IrfanView.
  2. Install the plugins pack.
  3. Open IrfanView.
  4. Click in the menu, Help -> Installed Plugins... then check on JPEG 2000.
  5. Click OK.

Links

Link-Wikipedia.png  Link-Official.png